//]]>-->

Wimp i ubuntu!

Wimp i ubuntu!

Innlegg søn 20.05.2012 15:45

Hei.

Har snoket litt rundt og prøvd litt å få lagt inn wimp i ubuntu (siste versjon) uten å lykkes..
noen som har tips? :-)
 
medlem i 81 måneder

Re: Wimp i ubuntu!

Innlegg søn 20.05.2012 16:46

Wimp krever Adobe Air, Adobe har droppet støtte for linux for Adobe Air, men binary filen ligger fremdeles tilgjengelig

Adobe AIR krever også noen filer for å fungere, for openSUSE x64 kreves disse filene:
Code: Select All Code
libasound2-32bit libgcc45-32bit libncurses5-32bit \
libxml2-32bit mozilla-nss-32bit mozilla-nspr-32bit gtk2-devel \
libxml2-devel-32bit libxml2-devel libxslt-32bit rpm-32bit rpm-devel \
libstdc++33-32bit libstdc++33-devel-32bit libgnome-keyring0-32bit \
gtk2-engine-murrine-32bit libcanberra-gtk3-module-32bit libcanberra-gtk3-0-32bit \
libcanberra-gtk0-32bit libcanberra-gtk2-module-32bit


Du må selv finne ut hvilke pakker som kreves, det finnes informasjon på adobes knowledge base. (Adobe AIR sier i fra hvilke pakker som mangler)

Laste ned Adobe AIR og installere
Code: Select All Code
wget -c http://airdownload.adobe.com/air/lin/download/2.6/AdobeAIRInstaller.bin
chmod +x AdobeAIRInstaller.bin
sudo ./AdobeAIRInstaller.bin


Edit: Rettet skriveleif i kommandoene
Sist endret av hailstiffler den søn 20.05.2012 17:37, endret 1 gang
 
medlem i 36 måneder

Re: Wimp i ubuntu!

Innlegg søn 20.05.2012 17:03

Ok. Takker for svar. Får opp dette under innstall:

ravn@ravn-P965T-A:~$ sudo ./AdobeAIRInstaller.bin
[sudo] password for ravn:
/tmp/air.8n4Gfj/setup: error while loading shared libraries: libgtk-x11-2.0.so.0: cannot open shared object file: No such file or directory

Peiling?
 
medlem i 81 måneder

Re: Wimp i ubuntu!

Innlegg søn 20.05.2012 17:14

tja, prøv med:
sudo apt-get install libgtk2.0-0
om ikke det funker så får du åpne synaptic og søke etter libgtk-x11 eller bare libgtk, det er mulig du også må installere devel pakkene. Jeg bruker ikke ubuntu så det er litt vanskelig for meg å finne ut hvilke pakker som mangler
 
medlem i 36 måneder

Re: Wimp i ubuntu!

Innlegg søn 20.05.2012 18:30

hmm.. ok..

Ser det ligger inne noe som heter libdtk-3-0

EDIT:
Et seg videre. kom meg fram til innstallasjonsprogrammet til AIR.
Fikk opp denne feilmeld.

Adobe AIR could not be installed. Install either Gnome Keyring or KDE KWallet before installing Adobe AIR.

Ser i synaptic den ligger inne Gnome Keyring
Sist endret av Raven80 den søn 20.05.2012 18:48, endret 1 gang
 
medlem i 81 måneder

Re: Wimp i ubuntu!

Innlegg søn 20.05.2012 18:48

som jeg skrev og nå skriver igjen, forsøk å installer: libgtk2.0-0

Altså
Code: Select All Code
sudo apt-get install libgtk2.0-0


http://packages.ubuntu.com/search?keywo ... ection=all

Om du har x86_x64 Kjerne så må du antageligvis symlinke gnome-keyring

Code: Select All Code
sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0 /usr/lib/libgnome-keyring.so.0
sudo ln -s /usr/lib/i386-linux-gnu/libgnome-keyring.so.0.2.0 /usr/lib/libgnome-keyring.so.0.2.0
 
medlem i 36 måneder

Re: Wimp i ubuntu!

Innlegg søn 20.05.2012 18:51

Hei.

ravn@ravn-P965T-A:~$ sudo apt-get install libgtk2.0-0Leser pakkelister ... Ferdig
Skaper oversikt over avhengighetsforhold
Leser tilstandsinformasjon ... Ferdig
libgtk2.0-0 er allerede nyeste versjon.

EDIT:

Flott dær har jeg AIR inne.. ;)

Har fått inn wimp nå

Takk for hjelpen:d ;)
 
medlem i 81 måneder

Re: Wimp i ubuntu!

Innlegg lør 29.12.2012 14:54

Hei!

Jeg har kommet så langt at jeg får åpnet installeren til Adove Air, men etter å ha godtatt vilkår osv, gir installeren meg følgende melding:

Sorry, an error has accured!
An error occurred while installing Adobe AIR. Installation may not be allowed by your administrator. Please contact your administrator.


Dette er koden jeg kjørte:

Code: Select All Code
sudo ./AdobeAIRInstaller.bin
[sudo] password for einar:


har også kjørt
Code: Select All Code
sudo su
Kong-Harald einar # ./AdobeAIRInstaller.bin
No protocol specified

(/tmp/air.7M29jK/setup:3440): Gtk-WARNING **: cannot open display:


men uten hell.

noen ideer?
 
medlem i 33 måneder

Re: Wimp i ubuntu!

Innlegg søn 03.03.2013 10:08

Bumper denne tråden litt.

Har ein kamerat som eg vurderer å hjelpe med laptopen & installere Ubuntu i staden for Windofs.

Bruksområdet hans er ikkje akkurat slik at han må ha Win. Men, han vil gjerne ha Wimp. Og her ser eg eit potensielt problem.

Eg har sjølv (for det meste) mac - og der virkar det.

Men, for Ubuntu? Nokon som kan hjelpe meg å forstå / få til installasjon av Wimp her?


 
medlem i 106 måneder

Re: Wimp i ubuntu!

Innlegg søn 03.03.2013 12:35

Hei.

Jeg brukte denne, men det forutsetter at du har 64bit:D se link.

http://www.teknologia.no/2010/03/7-steg ... ux-64-bit/
 
medlem i 81 måneder

Re: Wimp i ubuntu!

Innlegg søn 03.03.2013 15:14

Skal installere ny Ubuntu, så kan godt gå for 64. Men, den guiden, og din vurdering av den? Fungerar dette?

På min Mac føler eg det er oppgraderingar til Wimp kvar veke, korleis vert dette? Dersom eg installerar Ubuntu, og Wimp, ville det vore best (spesielt for meg) at det ikkje blir knot rundt neste sving :-!


 
medlem i 106 måneder

Re: Wimp i ubuntu!

Innlegg søn 03.03.2013 19:01

Hei.!

Ja med den guiden fungerer wimp smertefritt, Først og fremst må du laste ned en versjon av Adobe Air. Men alt dette står i guiden. ;)

Synes ikke det mye oppdateringer, kommer en i ny og ne. :-)

Kjør på du får til dette! ;)
 
medlem i 81 måneder


Returner til Ubuntu


Hvem er i Forumene

Brukere som leser i dette forumet: Ingen registrerte brukere og 1 gjest