//]]>-->

Problemer med å få opp conky

Generell diskusjon om Linux og fri programvare, ikke et support forum.

Problemer med å få opp conky

Innleggav ynos82 » man 14.01.2013 10:46

Har slettet conky fra maskinen og prøvd å re-installere det.

Jeg følger denne toturialen http://community.linuxmint.com/tutorial/view/545 og alt har egentlig gått ganske fint helt til jeg restartet pc'n og skulle starte conky. Jeg skriver conky men ingen conky dukker opp... det eneste jeg blir møtt med er:

Conky: /home/henrik/.conkyrc: 40: no such configuration: 'border_margin'
Conky: desktop window (1200029) is subwindow of root window (14e)
Conky: window type - override
Conky: drawing to created window (0x2a00001)
Conky: drawing to double buffer
--2013-01-10 14:18:58-- http://whatismyip.org/
Resolving whatismyip.org (whatismyip.org)... 23.21.24.107, 54.242.236.155, 184.72.161.18, ...
Connecting to whatismyip.org (whatismyip.org)|23.21.24.107|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 4809 (4,7K) [text/html]
Saving to: `STDOUT'

100%[======================================>] 4809 --.-K/s in 0,003s

2013-01-10 14:18:58 (1,49 MB/s) - written to stdout [4809/4809]


Om jeg fårstår dette rett:

Conky: /home/henrik/.conkyrc: 40: no such configuration: 'border_margin'

Så er det linje 40 i .conkyrc problemet ligger?,
dette er linje 40: border_margin 5

Poster med .conkyrc'n som jeg bruker under
Kode: Merk alt
# Use Xft?
use_xft yes
xftfont DejaVu Sans:size=8
xftalpha 0.8
text_buffer_size 2048

# Update interval in seconds
update_interval 1

# This is the number of times Conky will update before quitting.
# Set to zero to run forever.
total_run_times 0

# Create own window instead of using desktop (required in nautilus)
own_window yes
own_window_transparent yes
own_window_type override
#own_window_hints undecorated,below,sticky,skip_taskbar,skip_pager

# Use double buffering (reduces flicker, may not work for everyone)
double_buffer yes

# Minimum size of text area
minimum_size 182 0
maximum_width 182

# Draw shades?
draw_shades no

# Draw outlines?
draw_outline no

# Draw borders around text
draw_borders no

# Stippled borders?
stippled_borders 0

# border margins
border_margin 5

# border width
border_width 1

# Default colors and also border colors
default_color white
#default_shade_color black
#default_outline_color white
own_window_colour white

# Text alignment, other possible values are commented
#alignment top_left
alignment top_right
#alignment bottom_left
#alignment bottom_right

# Gap between borders of screen and text
# same thing as passing -x at command line
gap_x 30
gap_y 49

# Subtract file system buffers from used memory?
no_buffers yes

# set to yes if you want all text to be in uppercase
uppercase no

# number of cpu samples to average
# set to 1 to disable averaging
cpu_avg_samples 2

# number of net samples to average
# set to 1 to disable averaging
net_avg_samples 2

# Force UTF8? note that UTF8 support required XFT
override_utf8_locale yes

# Add spaces to keep things from moving about?  This only affects certain objects.
use_spacer none

TEXT
SYSTEM ${hr 2}
${goto 6}${voffset 6}${font OpenLogos:size=22}u${font}${goto 36}${voffset -18}${pre_exec cat /etc/issue.net} $machine
${goto 36}Kernel: ${kernel}
${hr 2}

${goto 6}${font StyleBats:size=16}A${font}${voffset -4}${goto 32}CPU1: ${cpu cpu0}% ${alignr}${cpubar cpu0 8,60}
${goto 6}${voffset 4}${font StyleBats:size=16}A${font}${voffset -4}${goto 32}CPU2: ${cpu cpu1}% ${alignr}${cpubar cpu1 8,60}
${goto 6}${voffset 4}${font StyleBats:size=16}g${font}${voffset -4}${goto 32}Memory: ${mem} ${alignr}${membar 8,60}
${goto 6}${voffset 4}${font StyleBats:size=16}x${font}${voffset -4}${goto 32}Disk: ${diskio}${alignr}${diskiograph 8,60 F57900 FCAF3E}
${goto 6}${voffset 4}${font StyleBats:size=16}j${font}${voffset -4}${goto 32}Swap: $swapperc% ${alignr}${swapbar 8,60}
${goto 4.5}${voffset 2}${font Poky:size=15}y${font}${voffset -6}${goto 32}HDD temperature:${alignr}${color #FCAF3E}${exec hddtemp /dev/sda -n --unit=C} °C$color
${goto 6}${voffset 4}${font StyleBats:size=16}q${font}${voffset -4}${goto 32}Uptime: ${alignr}${uptime}
${goto 6}${voffset 4}${font StyleBats:size=16}k${font}${voffset -4}${goto 32}Processes: ${alignr}$processes ($running_processes running)
${goto 7.5}${voffset 4}${font Poky:size=15}a${font}${goto 32}${voffset -10}Highest: ${alignr 13}CPU${alignr}RAM
${goto 32}${voffset -5.5}${hr 1}
${voffset -1}${goto 32}${top name 1} ${goto 124}${top cpu 1}${alignr }${top mem 1}
${voffset -1}${goto 32}${top name 2} ${goto 124}${top cpu 2}${alignr }${top mem 2}
${voffset -1}${goto 32}${top name 3} ${goto 124}${top cpu 3}${alignr }${top mem 3}
${voffset -1}${goto 32}${top name 4} ${goto 124}${top cpu 4}${alignr }${top mem 4}

Time & Date ${hr 2}
${font Arial Black:size=26}${alignc}${time %H:%M}${font}
${alignc}${time %A, %B %d, %Y}

HDD ${hr 2}
${font Poky:size=16}y${font} ${voffset -5}File System
${voffset 4}${fs_free /}/${fs_size /} ${alignr}${fs_bar 8,60 /}
${font Poky:size=16}y${font} ${voffset -5}Home
${voffset 4}${fs_free /home}/${fs_size /home} ${alignr}${fs_bar 8,60 /home}

Network ${hr 2}
${if_up wlan0}
${font Poky:size=14}Y${font}${goto 32}${voffset -8}SSID: ${wireless_essid wlan0}
${goto 32}Signal: ${wireless_link_qual wlan0}% ${alignr}${wireless_link_bar 8,60 wlan0}
${voffset 4}${font VariShapes Solid:size=14}q${font}${goto 32}${voffset -6}Up: ${upspeed wlan0}${font} ${alignr}${upspeedgraph wlan0 8,60 F57900 FCAF3E}
${goto 32}Total: ${totalup wlan0}
${voffset 4}${font VariShapes Solid:size=14}Q${font}${goto 32}${voffset -6}Down: ${downspeed wlan0}${font} ${alignr}${downspeedgraph wlan0 8,60 F57900 FCAF3E}
${goto 32}Total: ${totaldown wlan0}
${voffset 4}${font Poky:size=13}w${font}${goto 32}${voffset -8}Local IP: ${alignr}${addr wlan0}
${goto 32}Public IP: ${alignr}${execi 3600 wget -O - http://whatismyip.org/ | tail}
# |--ETH0
${else}${if_up eth0}
${voffset -13}${font VariShapes Solid:size=14}q${font}${goto 32}${voffset -6}Up: ${upspeed eth0}${font} ${alignr}${upspeedgraph eth0 8,60 F57900 FCAF3E}
${goto 32}Total: ${totalup eth0}
${voffset -2}${font VariShapes Solid:size=14}Q${font}${goto 32}${voffset -6}Down: ${downspeed eth0}${font} ${alignr}${downspeedgraph eth0 8,60 F57900 FCAF3E}
${goto 32}Total: ${totaldown eth0}
${voffset -2}${font Poky:size=13}w${font}${goto 32}${voffset -4}Local IP: ${alignr}${addr eth0}
${goto 32}Public IP: ${alignr}${execi 3600 wget -O - http://whatismyip.org/ | tail}
# |--PPP0
${endif}${else}${if_up ppp0}
${voffset -13}${font VariShapes Solid:size=14}q${font}${goto 32}${voffset -6}Up: ${upspeed ppp0}${font} ${alignr}${upspeedgraph ppp0 8,60 F57900 FCAF3E}
${goto 32}Total: ${totalup ppp0}
${voffset -2}${font VariShapes Solid:size=14}Q${font}${goto 32}${voffset -6}Down: ${downspeed ppp0}${font} ${alignr}${downspeedgraph ppp0 8,60 F57900 FCAF3E}
${goto 32}Total: ${totaldown ppp0}
${voffset -2}${font Poky:size=13}w${font}${goto 32}${voffset -4}Local IP: ${alignr}${addr ppp0}
${endif}${else}${voffset 4}${font PizzaDude Bullets:size=12}4${font}${goto 32}Network Unavailable${endif}${endif}
medlem i 81 måneder
 

Re: Problemer med å få opp conky

Innleggav moma » tir 15.01.2013 9:58

Hei,
Den lenken til "92328-conky_colors.tar.gz" er ikke lenger aktiv. Har du fått tak i den filen?
Jeg anbefaler at du begynner med eksempler som fungerer bra. Ta en titt på
http://ubuntuforums.org/showthread.php?t=281865

Her er noen andre eksempler (men oppsett varierer fra kasus til kasus).
http://desktopspotting.com/26/best-conk ... x-desktop/

Terminer og omstart conky mellom hver test.
$ killall conky
$ conky &
Legg til "conky" i oppstart-dialogen slik at den startes ved første login.

EDIT: Den border_margin feilen er ikke alvorlig.
Fortell oss hva som fungerte bra.

Erfaren
Brukerens avatar
medlem i 178 måneder
 

Re: Problemer med å få opp conky

Innleggav ynos82 » tir 15.01.2013 10:18

Hei takk for svar. Ja jeg fikk tak i 92328-conky_colors.tar.gz etter litt googling.

Men jeg har gjort alt helt til restart. Er det noe jeg må gjøre før jeg titter på forumet du ga meg ? Altså å jeg slette noe før jeg begynner på noe nytt for at det skal fungere? I så fall hvordan. Tusen takk for alle svar, hjelper meg utrolig mye :)
medlem i 81 måneder
 

Re: Problemer med å få opp conky

Innleggav moma » tir 15.01.2013 13:24

Hei,
0) Du har allerede installert alle nødvendige conky-pakker (slik instruert av guiden):
$ sudo apt-get install conky-all conky curl hddtemp lm-sensors python-statgrab
$ sudo chmod u+s /usr/sbin/hddtemp

1) Denne kommandoen vil detektere sensorer for temperatur og viftehastighet på CPU/GPU og kasse. Den aktiverer også nødvendige drivere. Kommandoen krever som regel omstart.
$ sudo sensors-detect
Du kan kjøre denne mange ganger. Bruk default-svar (ENTER-tast) på alle spørsmål.
Husk å svar Yes/Ja på det siste spørsmålet:
Do you want to add these lines automatically to /etc/modules? (yes/NO): yes

2) Du trenger kun å erstatte $HOME/.conkyrc med nytt innhold, og omstarte selve conky-prosessen. Editer og lagre din nye $HOME/.conkyrc (ikke bruk sudo!)
$ gedit $HOME/.conkyrc

Terminer og omstart conky mellom hver test.
$ killall conky
$ conky &

3) Legg til "conky" kommando i oppstart-dialogen slik at den startes ved første login.
Det var alt ;-)

EDIT: -c argumentet lar deg bruke forskjellige konfigurasjonsfiler og vise flere conky'er på samme desktop.
$ conky -c din-conkyrc-1 &
$ conky -c din-conkyrc-2 &
Noen sære oppsett fungerte kun i nyeste Ubuntu 12.10. Noen av eksemplene kom med egne ikoner, filer samt startup skript.

Erfaren
Brukerens avatar
medlem i 178 måneder
 

Re: Problemer med å få opp conky

Innleggav ynos82 » ons 16.01.2013 11:20

Takk for all hjelpen. Sånn her ser det ut til nå :) Får bare holdt på med dette da jeg er på jobb så ikke så veldig mye med andre ord.
Får ikke alt til å funke som det skal som du kan se under. Batteriet endrer seg ikke samme med WiFi Signal og så er den litt kranglete med Local Ip.
På Local Ip så måtte jeg sette inn ${addr eth0} får at den i det hele tatt skulle endre seg viss ikke hadde det stått No address hele tiden. Så den linjen ser nå ut sånn her:
Kode: Merk alt
Local Ip:   ${addr eth0}${alignr}${addr wlan1}

Andre jeg har endret på er Teksten på toppen og den lille logoen. Skulle ønske jeg hadde fått de siste tingene til å funke også.
Her har du to screens under, en med kabel og en på trådløst nett.

Bilde Bilde


Ahh fikk fikset det nå :)
medlem i 81 måneder
 


Returner til Generell diskusjon



Hvem er i Forumene

Registrerte brukere: Google [Bot]