Installere libqt4-core og gui versjon 4.8 i Debian

Alt som er relatert til nettverk og tjenester for nettverk, inklusive konfigurasjon av trådløse nettverk.

Installere libqt4-core og gui versjon 4.8 i Debian

Innleggav goofygutt » man 06.05.2013 22:00

Jeg prøver å få Aircrack-ng M4 GUI til å starte, men når jeg kjører det får jeg en feilmelding som sier
Kode: Merk alt
root@debian:/home/myusername/AircrackGUI# ./aircrack-GUI-Start.sh
***********************************************************
This program requires:
libqt4-core version 4.8.0
libqt4-gui version 4.8.0
***********************************************************
***********************************************************
Exporting LD_LIBRARY_PATH (To include actual folder)...
***********************************************************
***********************************************************
Executing Aircrack M4!
***********************************************************
./aircrack-GUI: symbol lookup error: ./aircrack-GUI: undefined symbol: _ZN9QListData11detach_growEPii
***********************************************************
PULSE ENTER TO EXIT
***********************************************************


Jeg har forstått det slik at feilmeldingen kommer pga feil versjon av libqt4 greiene.
Jeg har kjørt apt-get install libqt4.core og libqt4-gui men jeg tror jeg får utlevert versjon 4.6 mens programmet krever 4.8.

Kan jeg laste ned nyere versjon av bibliotekene noen sted? Eller er det min distro som ikke støtter 4.8?

Jeg har følgende distro: Debian 2.6.32-48squeeze1
medlem i 143 måneder
 

Re: Installere libqt4-core og gui versjon 4.8 i Debian

Innleggav ak » ons 08.05.2013 15:21

Kan ikke si noe om det er riktig diagnose, men enkleste måte å få Qt 4.8 på er antageligvis å oppgradere til Wheezy (Debian 7), som ble lansert for et par dager siden.

http://www.debian.org/News/2013/20130504

Ellers kan du bygge selv og bruke LD_LIBRARY_PATH for å foretrekke disse:
http://download.qt-project.org/official ... mirrorlist

Å bygge Qt er som regel lett, bare kjøre "make", men du må antageligvis installere en del avhengigheter.

Administrator
Brukerens avatar
medlem i 202 måneder
 

Re: Installere libqt4-core og gui versjon 4.8 i Debian

Innleggav goofygutt » fre 10.05.2013 19:33

det funket faktisk å oppgradere, litt utrolig at hele operativsystemet må oppgraderes for at et program skal funke.
LXDE sluttet å funke etter installasjonen da :( dumt, for GNOME 3 var rævva
medlem i 143 måneder
 

Re: Installere libqt4-core og gui versjon 4.8 i Debian

Innleggav ak » fre 10.05.2013 21:21

Vel, det henger jo på AirCrack-folkene. Hvis de bruker Qt-funksjonalitet som bare er tilgjengelig i (nesten) siste versjon så er man pent nødt til å bruke det.

Kjører du Debian stable så vil du ofte komme borti det, men nesten aldri om du bruker Debian unstable. Og sistnevnte kan heller ikke betegnes som ustabil for skrivebordsbruk.

Administrator
Brukerens avatar
medlem i 202 måneder
 

Re: Installere libqt4-core og gui versjon 4.8 i Debian

Innleggav terjejh » man 13.05.2013 16:47

goofygutt skrev:det funket faktisk å oppgradere, litt utrolig at hele operativsystemet må oppgraderes for at et program skal funke.
LXDE sluttet å funke etter installasjonen da :( dumt, for GNOME 3 var rævva

Qt 4.8.0 ble released 15.des. 2011, mens dagens siste stabile utgave 4.8.4 ble sluppet 29. nov. 2012. De forskjellige distribusjonene har vel her noe forskjellig policy mht oppgraderinger og tilbakeportering til tidligere distro-versjoner. Eksempelvis er Qt 4.8 tilgjengelig for hele openSUSE 12.x serien, for 11.4 (nå Evergreen, LTS) og SLE-11 http://download.opensuse.org/repositories/KDE:/Qt48/

Appropos, hvilken versjon av og hva i "GNOME 3 var rævva"?

Erfaren
Brukerens avatar
medlem i 182 måneder
 


Returner til Nettverk / Sikkerhet



Hvem er i Forumene

Registrerte brukere: Ingen registrerte brukere