Mplayer og MKV problemer

Annen programvare du prøver å kjøre under Linux, inklusive WINE

Mplayer og MKV problemer

Innleggav NewBee-Petter » fre 24.08.2012 18:53

Hei, jeg har problemer med å spille av MKV filer i Mplayer. Filmen funker fint med Totem.
Her er et lite utklipp fra hva som skjer:

mplayer Film.mkv
mplayer: Symbol `ff_codec_bmp_tags' has different size in shared object, consider re-linking
MPlayer 1.0rc4-4.5.2 (C) 2000-2010 MPlayer Team
mplayer: could not connect to socket
mplayer: No such file or directory
Failed to open LIRC support. You will not be able to use your remote control.

Playing Film.mkv.
[mkv] Track 1 has been compressed with an unknown/unsupported compression
[mkv] algorithm (3). Skipping track.
[mkv] Track 2 has been compressed with an unknown/unsupported compression
[mkv] algorithm (3). Skipping track.
[mkv] Track ID 1: video (V_MPEG4/ISO/AVC), -vid 0
[mkv] Track ID 2: audio (A_DTS), -aid 0, -alang und
[mkv] Will play video track 1.
Matroska file format detected.
VIDEO: [avc1] 1280x528 24bpp 23.976 fps 0.0 kbps ( 0.0 kbyte/s)
SUB: Added subtitle file (1): ./Film.srt
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
open: No such file or directory
[MGA] Couldn't open: /dev/mga_vid
[VO_TDFXFB] Can't open /dev/fb0: Permission denied.
[VO_3DFX] Unable to open /dev/3dfx.
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
[dca @ 0x7faf35f43120]Not a valid DCA frame
[dca @ 0x7faf35f43120]Not a valid DCA frame
[dca @ 0x7faf35f43120]Not a valid DCA frame
[dca @ 0x7faf35f43120]Not a valid DCA frame
[dca @ 0x7faf35f43120]Not a valid DCA frame
[dca @ 0x7faf35f43120]Not a valid DCA frame
Unknown/missing audio format -> no sound
ADecoder init failed :(
Opening audio decoder: [libdca] DTS decoding with libdca

Too many video packets in the buffer: (2054 in 33569137 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
dts sync failed
ADecoder init failed :(
ADecoder init failed :(
Opening audio decoder: [hwac3] AC3/DTS pass-through S/PDIF

Brukerens avatar
medlem i 188 måneder
 

Re: Mplayer og MKV problemer

Innleggav aNordal » lør 25.08.2012 3:04

Kode: Merk alt
Symbol has different size in shared object, consider re-linking
betyr at Mplayer er installert feil. Du kan løse problemet ved å kompilere Mplayer selv. Hvis du har installert Mplayer på den måten som er anbefalt av din distro, kan du rapportere til distroen din.
medlem i 187 måneder
 

Re: Mplayer og MKV problemer

Innleggav NewBee-Petter » lør 25.08.2012 12:04

Takker for svar, fant senere ut at dette var en bug i mplayer som faktisk var rapportert i 2009/2010, men som fortsatt dukker opp av og til. Har lest litt rundt, men ingen gode løsninger som fikser dette.
Jeg snublet over en "fork" av mplayer, mplayer2 (virkelig fantasiløst navnevalg), men denne fungerer på de filmene som jeg har problemer med. http://www.mplayer2.org/
Så dette får være løsningen så lenge.

Håper bare den config filen er 100% kompatibel. :-)

Brukerens avatar
medlem i 188 måneder
 


Returner til Annen programvare / Spill



Hvem er i Forumene

Registrerte brukere: Google [Bot]