KDE4.2 i Suse 11.1

KDE4.2 i Suse 11.1

Innleggav Derox » lør 29.11.2008 22:25

Hei, hvordan installerer man KDE4.2 i Suse 11.1
medlem i 216 måneder
 

Re: KDE4.2 i Suse 11.1

Innleggav terjejh » søn 30.11.2008 0:52

omaha er utvilsomt den rette til å svare på dette.
Man skal vite hva man gjør også mht retrettmuligheter (UNSTABLE desktop). Repoet finnes via denne linken
http://en.opensuse.org/KDE4#UNSTABLE_KD ... _Beta_1.29

Erfaren
Brukerens avatar
medlem i 198 måneder
 

Re: KDE4.2 i Suse 11.1

Innleggav Derox » søn 30.11.2008 12:44

Yes, takk for det! Jeg har også funnet den, lagt den til og prøvd å oppgradere, men jeg får feilmelding at den ikke finner avhengighetene - som soleklart ligge i det repoet da jeg har mauelt kikka gjennom filene som ligger der... :-[
medlem i 216 måneder
 

Re: KDE4.2 i Suse 11.1

Innleggav Soerboe » søn 30.11.2008 19:07

et alternativ da er jo å manuelt laste ned avhengighetene og installere de først, selv om det ikke er vakkert...

Brukerens avatar
medlem i 184 måneder
 

Re: KDE4.2 i Suse 11.1

Innleggav KMJ » søn 30.11.2008 19:53

Tror det kan skje fra tid til annen, har vært borti noe av det samme når filene i pakkebrønnen har blitt oppdatert midt under min nedlasting/oppdatering.

Som regel bruker det å ordne seg med å prøve igjen litt senere, og pass på at pakkebehandleren er satt opp til å synkronisere med pakkebrønnen under oppstart.

Erfaren
medlem i 201 måneder
 

Re: KDE4.2 i Suse 11.1

Innleggav omaha » man 01.12.2008 12:11

Jeg brukte ymp basis, og om jeg ikke husker feil - ymp development. Det skal ikke være problemer med qt 4.5 slik det var til å begynne med i 11.0 ved oppgradering til 4.1, men pass på at pakker hentes for 11.1 og ikke 11.0 eller factory. Det finnes jo også en KDE Live 4.2 man kan teste med på KDE's sider

Dette er jo beta og det er mange oppdateringer til 11.1 av og til, så strengt tatt er ikke dette noe for "production" systemer. Vær også oppmerksom på at det ikke er lagt ut propietær driver for Nvidia GPU. Nvidia 180.08 BETA kompilerte greit i 11.1.

Jeg har brukt 11.1 RC KDE 4.2 noen dager nå, og det sviver greit på min T61. Det eneste er at Powerdevil er litt krøllete, Networkmanager er KDE 3, og kwin kan crashe ved enkelte plasmoids (dukker plutselig opp 4 av hver). Så vær konservativ med plasmoids.

Ellers fungerer det bra. Dersom man legger inn temaet "skulptur" (Sjekk webpin), kan man teste konfigurasjonsmulighetene på temaer.

Det er mange forbedringer fra KDE 4.1, og fra mitt ståsted vil KDE 4 bli bedre enn OSX' desktop også. Men den er jo ikke klar før i Januar, og beta ER beta. Dersom desktop'en skulle krashe - logg inn med annen vindusbehandler og fjern .KDE4 fra hjemmekatalogen (gi den nytt navn), og gå inn igjen med KDE 4. Det løser som regel problemet.......
medlem i 186 måneder
 

Re: KDE4.2 i Suse 11.1

Innleggav Derox » man 01.12.2008 17:23

Hvis jeg klikker på basis.ymp får jeg:

#### YaST2 conflicts list - generated 2008-12-01 16:22:29 ####

powerdevil-1.4.1-3.5.x86_64 krever libplasma.so.2()(64bit), men denne nødvendige filen finnes ikke

[ ] Følgende handlinger vil bli utført:
Ikke installer kdebase4-workspace-4.1.81-1.2.x86_64
Ikke installer kde4-dolphin-4.1.81-1.2.x86_64
Ikke installer kde4-kfind-4.1.81-1.2.x86_64
Ikke installer kde4-kdialog-4.1.81-1.2.x86_64
Ikke installer kde4-kdepasswd-4.1.81-1.2.x86_64
[ ] avinstallasjon av powerdevil-1.4.1-3.5.x86_64

[ ] Ignorer noen avhengigheter for powerdevil



kde4-plasmoid-quicklauncher-0.4-4.11.x86_64 krever libplasma.so.2()(64bit), men denne nødvendige filen finnes ikke

[ ] Følgende handlinger vil bli utført:
Ikke installer kde4-kwin-4.1.81-1.2.x86_64
Ikke installer kde4-dolphin-4.1.81-1.2.x86_64
[ ] avinstallasjon av kde4-plasmoid-quicklauncher-0.4-4.11.x86_64

[ ] Ignorer noen avhengigheter for kde4-plasmoid-quicklauncher



kdelibs4-4.1.3-4.3.x86_64 krever libkde4 = 4.1.3, men denne nødvendige filen finnes ikke

[ ] Følgende handlinger vil bli utført:
Ikke installer kdebase4-4.1.81-1.2.x86_64
Ikke installer kde4-dolphin-4.1.81-1.2.x86_64
Ikke installer kde4-kdialog-4.1.81-1.2.x86_64
[ ] avinstallasjon av kde4-knewsticker-4.1.3-4.5.x86_64

[ ] Ignorer noen avhengigheter for kdelibs4



kde4-plasmoid-quickaccess-0.7.1-4.11.x86_64 krever libplasma.so.2()(64bit), men denne nødvendige filen finnes ikke

[ ] Følgende handlinger vil bli utført:
Ikke installer kdebase4-session-4.1.81-1.2.x86_64
Ikke installer kde4-dolphin-4.1.81-1.2.x86_64
[ ] avinstallasjon av kde4-plasmoid-quickaccess-0.7.1-4.11.x86_64

[ ] Ignorer noen avhengigheter for kde4-plasmoid-quickaccess



skanlite-0.2-3.8.x86_64 krever kdebase4-runtime < 4.1.60, men denne nødvendige filen finnes ikke
uinstallerbare nødvendige pakker: kdebase4-runtime-4.1.3-2.4.i586[repo-oss]
[ ] Følgende handlinger vil bli utført:
Ikke installer kde4-kwrite-4.1.81-1.2.x86_64
Ikke installer kde4-kdialog-4.1.81-1.2.x86_64
Ikke installer kde4-kdepasswd-4.1.81-1.2.x86_64
[ ] avinstallasjon av skanlite-0.2-3.8.x86_64

[ ] Ignorer noen avhengigheter for skanlite



compiz-kde4-0.7.8-6.4.x86_64 krever libplasma.so.2()(64bit), men denne nødvendige filen finnes ikke

[ ] avinstallasjon av compiz-kde4-0.7.8-6.4.x86_64

[ ] Ikke installer kde4-kmix-4.1.81-1.2.x86_64

[ ] Ignorer noen avhengigheter for compiz-kde4



kde4-konqueror-plugins-4.1.3-2.1.x86_64 krever kdebase4-runtime < 4.1.60, men denne nødvendige filen finnes ikke
uinstallerbare nødvendige pakker: kdebase4-runtime-4.1.3-2.4.i586[repo-oss]
[ ] Følgende handlinger vil bli utført:
Ikke installer kde4-konsole-4.1.81-1.2.x86_64
Ikke installer kde4-kdepasswd-4.1.81-1.2.x86_64
[ ] nedgradering av kde4-konqueror-plugins-4.1.3-2.1.x86_64 til kde4-konqueror-plugins-4.1.3-1.6.x86_64

[ ] Ignorer noen avhengigheter for kde4-konqueror-plugins



kde4-kgreeter-plugins-4.1.3-9.5.x86_64 krever kdebase4-runtime < 4.1.60, men denne nødvendige filen finnes ikke
uinstallerbare nødvendige pakker: kdebase4-runtime-4.1.3-2.4.i586[repo-oss]
[ ] avinstallasjon av kde4-kgreeter-plugins-4.1.3-9.5.x86_64

[ ] Ikke installer kde4-konqueror-4.1.81-1.2.x86_64

[ ] Ignorer noen avhengigheter for kde4-kgreeter-plugins



kde4-kdm-4.1.3-9.5.x86_64 krever kde4-kgreeter-plugins = 4.1.3, men denne nødvendige filen finnes ikke
uinstallerbare nødvendige pakker: kde4-kgreeter-plugins-4.1.3-9.4.i586[repo-oss]
[ ] avinstallasjon av kde4-amarok-1.98-1.5.x86_64

[ ] Ikke installer kde4-keditbookmarks-4.1.81-1.2.x86_64

[ ] Ignorer noen avhengigheter for kde4-kdm




#### YaST2 conflicts list END ###
medlem i 216 måneder
 

Re: KDE4.2 i Suse 11.1

Innleggav omaha » tir 02.12.2008 12:15

Tror du bør legge inn KDE Xtra og Community for 11.1 også. for å få rett versjon av Amarok og Koffice.... Compiz behøves igrunn ikke - Kwin begynner å bli bra - jeg har ihvertfall fjernet Compiz helt.

Ellers er det vel snakk om å velge følgende om jeg ikke tar feil:

[ ] avinstallasjon av powerdevil-1.4.1-3.5.x86_64
[ ] avinstallasjon av kde4-plasmoid-quicklauncher-0.4-4.11.x86_64
[ ] avinstallasjon av kde4-knewsticker-4.1.3-4.5.x86_64
[ ] avinstallasjon av kde4-plasmoid-quickaccess-0.7.1-4.11.x86_64
[ ] avinstallasjon av skanlite-0.2-3.8.x86_64
[ ] avinstallasjon av compiz-kde4-0.7.8-6.4.x86_64
[ ] nedgradering av kde4-konqueror-plugins-4.1.3-2.1.x86_64 til kde4-konqueror-plugins-4.1.3-1.6.x86_64
[ ] Ikke installer kde4-keditbookmarks-4.1.81-1.2.x86_64

Jeg kan ikke se at dette skulle medføre noen problemer - ankepunktet vil vel være powerdevil på laptops (bruk powermanager istedet), og plasmoid quicklauncher vil kanskje være noe du ønsker å titte på - men essensielt er det nok ikke..

Edit:
[ ] avinstallasjon av kde4-kgreeter-plugins-4.1.3-9.5.x86_64
Jeg fikk et problem i forbindelse med kgreeter... Men jeg mistet nettforbindelsen under oppdatering, så jeg er usikker på om det faktisk var Kgreeter som lagde krøll...
Forsiktighet kan være på sin plass....
medlem i 186 måneder
 

Re: KDE4.2 i Suse 11.1

Innleggav Derox » tir 02.12.2008 18:05

Javel ja, skjønner :D Flott!!

Hvor finner jeg KDE Xtra og Community for 11.1?

Edit: OK, jeg fant det ut selv :)
medlem i 216 måneder
 

Re: KDE4.2 i Suse 11.1

Innleggav omaha » ons 03.12.2008 14:04

Åpenbart er det en risiko ved å anvende en RC med et "Unstable Beta" skrivebordsmiljø osv, så dette er nok ikke for produksjonsmiljø enda.

Jeg fikk et problem pga egen uoppmerksomhet da Suse slapp pakkene for neste versjon (OpenSuse 11.2 Alpha 0) i Factory og de er nok ikke klare for daglig bruk ;o))

Utover dette er jeg svært tilfreds med kombinasjonen og kommer til å anvende den fremover.

OpenSuse er ute med 11.1 rc2 internt, og de har fortsatt som mål å slipp "gold master" i morgen med lansering av 11.1 18 desember. KDE 4.2 ser ut til å være i rute for slutten av januar. KDE 4.2 final burde være godt anvendbar for "de fleste" med mindre de har spesifikke behov som ikke dekkes, og med KDE 4.3 vil dette bli referansen som andre skrivebordsmiljø måles etter - uansett OS - tror jeg.
medlem i 186 måneder
 

Re: KDE4.2 i Suse 11.1

Innleggav Derox » fre 30.01.2009 15:46

Hei! Jeg bruker OpenSuse11.1, og rett etter installasjon og oppdatering gikk jeg for å hente KDE4.2.

Da jeg la det til fikk jeg spørsmål om å erstatte noen kde4.1 med 4.2 pakker, dette sa jeg ja til, samt at noen måtte enten nedgraderes eller avinstalleres, de nedgraderte jeg.

Etter hvert ble jeg plaget med at jeg Suse hele tiden bad om at jeg måtte sett inn DVD'n når jeg skulle legge til prgramvare/brønner. Så jeg fant ut at det gikk an å velge den bort som "brønn" og gjorde så det. Da måtte den endre på 61 pakker, skjønte ikke om det var oppgradering eller nedgradering.

Bare lurte på, høres dette ut som riktig metode å gjøre det på?

Nå har jeg noen duplikater liggende i menyen i alle fall, dvs for eksempel KDE4 og KDE3 terminaler, kate, o.l.

EDIT: Jeg lurer også på, er det mulig å få inn amarok 2 på noen måte? Når jeg velger å legge det til nå så vil den ha meg til å nedgradere til KDE4.1...

EDIT 2: Er det meningen jeg skal fjerne noen av de gamle pakkebrønnene?
De som f.eks heter Debug, Non-oss, Oss, Update og source?

I tillegg har jeg ati, kde4: community, kde 4: factory extra-apps, kde4: factory: desktop og packman...
medlem i 216 måneder
 

Re: KDE4.2 i Suse 11.1

Innleggav omaha » fre 30.01.2009 16:57

Jeg har ikke tid til å svare nå, men kort:

Ja du kan installere Amarok, og du trenger ikke fjerne oss og non oss.

Amarok bruker vel MySQL som database, og du bør kanskje aktivere Databaserepo.

Kan du liste de pakkebrønnene du har aktivert?

Jeg skal titte innom sent i ettermiddag/kveldingen.
medlem i 186 måneder
 

Re: KDE4.2 i Suse 11.1

Innleggav Derox » fre 30.01.2009 17:46

De jeg nevte nettopp er de jeg har aktivert, hvis du vil ha en slik fancy utskrift fra konsole fant jeg nettop ut hvordan jeg gjorde det, hehe:
Kode: Merk alt

| Alias                     | Name                      | Enabled | Refresh
---+---------------------------+---------------------------+---------+--------
1  | ATI Repository            | ATI Repository            | Yes     | Yes
2  | KDE4:_Community           | KDE4: Community           | Yes     | Yes
3  | KDE4:_Factory:_Extra-Apps | KDE4: Factory: Extra-Apps | Yes     | Yes
4  | KDE:KDE4:Factory:Desktop  | KDE:KDE4:Factory:Desktop  | Yes     | Yes
5  | KDE:Qt                    | KDE:Qt                    | Yes     | Yes
6  | Packman Repository        | Packman Repository        | Yes     | Yes
7  | repo-debug                | openSUSE-11.1-Debug       | No      | Yes
8  | repo-non-oss              | openSUSE-11.1-Non-Oss     | Yes     | Yes
9  | repo-oss                  | openSUSE-11.1-Oss         | Yes     | Yes
10 | repo-source               | openSUSE-11.1-Source      | No      | Yes
11 | repo-update               | openSUSE-11.1-Update      | Yes     | Yes
medlem i 216 måneder
 

Re: KDE4.2 i Suse 11.1

Innleggav omaha » fre 30.01.2009 19:45

Dersom alle disse er satt opp i forhold til 11.1 skal det være greit. Tror kanskje du bør legge inn databaserarkivet som jeg nevnte - husker jeg ikke feil krever Amarok en nyere versjon av MySQL.
Dersom du ikke driver aktivt med debugging trenger du ikke å ha repo-debug aktivert.

Jeg kan ikke se at du har update inkludert:

http://download.opensuse.org/update/11.1/

Du har Koffice 2.0 Beta 5 tilgjengelig i Xtra, men den oppfatter jeg som risikabel og ikke til annet enn uttesting. Den erstatter ikke Koffice, men kommer i tillegg.

Amarok har blitt flyttet til Core, så den er tilgjengelig der. Du finner også K3b i KDE 4.2 versjon (Jeg bruker fortsatt 3.5 versjonen), og Acetone iso 2 i Community.

Det er noen "essensielle" applikasjoner fra KDE 3.5 (Amarok, Kontact/KDEpim/Koffice tror jeg) som kom med OpenSuse fordi KDE 4.2 versjonen ikke var/er ferdig portet. Husker ikke avhengighetene men de gjør ingen skade. Fjerner du noen av de vær obs på avhengigheter. KDEpim/Kontact er nok fortsatt bedre mht sync mot mobile enheter enn 4.2 versjonene. Det ligger et bra Tema som heter Skulptur(e) i Community. Det lar deg redusere rammer til 0, minske fanehøyden og regulere det meste av bredde/høyde/vidde i GUI på pixelnivå.

Det er et par repos du kan legge til for å få codeks, VLC osv (Packman og VideoLan):
http://opensuse-community.org/Restricted_Formats/11.1

Dersom du vil ha siste utviklerversjon av Firefox:
http://download.opensuse.org/repositori ... SUSE_11.1/

Den nye versjonen av OpenOffice har blitt flyttet fra unstable og kan installeres fra OpenOffice Buildservice repo, men det ser ikke ut til at de Novellspesifikke tilleggene er klare enda. Jeg tror ikke det tar lang tid før de er tilgjengelige.

Vær oppmerksom på at når du kjører KDE 4.2 i OpenSuse, så er det Factory-versjon - dvs de er i utvikling, så det KAN hende at en oppdatering skjærer seg.

I såfall kan du ofte velge et annet DE (FMxxx) når du logger inn. I påvente av at pakkene i repo oppdateres og er brukbare igjen mener jeg.
medlem i 186 måneder
 

Re: KDE4.2 i Suse 11.1

Innleggav Derox » fre 30.01.2009 20:03

Hei, takker for solid svar.

Er ikke den nederste i lista update da?

Hmm, da jeg valgte å legge til Amarok 2 i yast bad den meg nedgradere 81 pakker, det meste kde4.2 pakker til kde4.1 pakker. Men nå gikk jeg via zypper, og det virka faktisk. Fikk en stygg feilmelding første oppstart, men nå ser den ut til å virke...
medlem i 216 måneder
 

Neste

Returner til OpenSUSE



Hvem er i Forumene

Registrerte brukere: Google [Bot]