problem med codecs

problem med codecs

Innleggav Philip67 » fre 21.05.2010 18:44

Hei.
Jeg har installert suse på en pc idag.da jeg vile installere media codecene fik jeg denne feil meldingen
http://bildr.no/image/651720.jpeg
Jeg prøvde de veldig mange ganger men fikk ikke til noe.Er edt noen som vet hva som er problem?
takk

Brukerens avatar
medlem i 151 måneder
 

Re: problem med codecs

Innleggav Tertitten » fre 21.05.2010 18:55

Problemet er akkurat hva feilmeldingen sier, Packagekit er allerede i bruk og tillater deg ikke å installere andre pakker mens den er i bruk. Mulig den kjører en annen installsjon eller oppdatering eller lignende.

Om du "tør" kan du "drepe" programmet ved å skrive (som root) kill -9 2849 (2849 = pid for packagekit i dette tilfellet, gjør deg sikker på at pid er fremdeles samme ved å f.eks skrive ps aux | grep packageki*, bytt ut evt annen pid i kill kommandoen)

Det er fult mulig det finnes en lurere måte å løse dette på, som f.eks ved å logg ut/inn :)

Brukerens avatar
medlem i 155 måneder
 

Re: problem med codecs

Innleggav Philip67 » fre 21.05.2010 19:18

Jeg prøvde å ta live av hans men fikk denne meldingen
bash: syntax error near unexpected token `('

Brukerens avatar
medlem i 151 måneder
 

Re: problem med codecs

Innleggav thelonelywolf » fre 21.05.2010 19:31

Hei
En rask restart av systemet bør få deg på skinnene igjen. Kan hende du klarer deg med en utlogging, men tviler litt der.
medlem i 165 måneder
 

Re: problem med codecs

Innleggav terjejh » fre 21.05.2010 20:00

Lignende pid-melding får jeg ofte når jeg skal starte zypper kort tid etter innlogging, sannsynligvis mens 'SUSE updater' også sjekker etter oppdatering i bakgrunnen.

Som root i terminalen er det da nok å skrive 'kill pidnr'. Riktignok svares det ofte noe sånt som at pidnr ikke finnes, men påfølgende nytt forsøk med zypper fungerer.

Erfaren
Brukerens avatar
medlem i 198 måneder
 

Re: problem med codecs

Innleggav Tertitten » fre 21.05.2010 21:08

Philip67 skrev:Jeg prøvde å ta live av hans men fikk denne meldingen
bash: syntax error near unexpected token `('

det er fordi du kopierte dette: (som root) kill -9 2849 og limte inn det, mens du skulle kun ha kopiert/skrevet inn kill -9 2849 :)

Brukerens avatar
medlem i 155 måneder
 


Returner til OpenSUSE



Hvem er i Forumene

Registrerte brukere: Google [Bot]