Språket til systemet

Re: Språket til systemet

Innleggav singer » søn 28.10.2012 1:09

er det denneYaST2 > System > Edit /etc/sysconfig, og den andre du ga meg jeg skal lime inn i terminal med su enter passord satt til pc ved install?

Er det mulig å laste ned nødvendig fil under legg til programer det er over 900 download under language noen som vet om jeg må laste ned alle?



Ser jeg kan installere language filer fra legg tilprogramer yaST ,siden jeg ikke har brukt terminal så kan det være en mulighte å laste disse filene.

Brukerens avatar
medlem i 185 måneder
 

Re: Språket til systemet

Innleggav terjejh » søn 28.10.2012 11:40

Ja, det er ditt brukerpassord fra installasjonen. Når du virker uvant med det, har du nok godtatt de automatiske installasjonsvalgene der rot får samme passord og at du selv har autologin til systemet.

Du skal ikke selv laste ned noen språkfiler via YaST2 pakkebehandleren. Hvis noe mangler, ordnes det via YaST språkoppsettet direkte.

Her får du se de to kommandoeksemplene og utskriftene, slik de skal være fra min maskin i et Gnome-terminal vindu:
Kode: Merk alt
terje@linux-c2pb:~> cat /etc/sysconfig/language | grep RC_LANG
# Local users will get RC_LANG as their default language, i.e. the
RC_LANG="nb_NO.UTF-8"

Kode: Merk alt
terje@linux-c2pb:~> gnome-shell --version
GNOME Shell 3.4.2

I terminal tar jeg videre 'su -' til root og gir inn passordet. Herfra kan den aktuelle YaST modulen startes direkte med kommandoen
'yast2 sysconfig' (jfr. øvre del av skjermbildet som følger):

Bilde
Som vist åpnes trestrukturen (+ tegnene) i venstre kollonne
>> System > Environment > Language > RC_LANG
og velg følgende innstillingsverdi fra lista som tas opp
nb_NO.UTF-8
Trykk OK
og YaST lagrer og avslutter

Logg ut og logg inn igjen

Erfaren
Brukerens avatar
medlem i 198 måneder
 

Re: Språket til systemet

Innleggav singer » søn 28.10.2012 12:58

Jeg skkriver su mellomrom og enter så passord, men får opp melding jeg publiserte i tidligere innlegg.limer inn en og en komando du ga meg, den første select code sier:

linux-na19:/home/sement # cat /etc/*release
NAME=openSUSE
VERSION="12.2 (Mantis)"
VERSION_ID="12.2"
PRETTY_NAME="openSUSE 12.2 (Mantis) (x86_64)"
ID=opensuse
ANSI_COLOR="0;32"
CPE_NAME="cpe:/o:opensuse:opensuse:12.2"
openSUSE 12.2 (x86_64)
VERSION = 12.2
CODENAME = Mantis

gnome-shell --version
Ble bare surr får ikke opp noe som ligner det du fikk opp i terminal
GNOME Shell 3.4.2

Brukerens avatar
medlem i 185 måneder
 

Re: Språket til systemet

Innleggav terjejh » søn 28.10.2012 13:20

Kan du ta den øverste kommandoen jeg limte inn i forrige innlegg? Du behøver ikke være rot, vanlig bruker.

Root behøver du bare være for å starte YaST modulen, og da tar du
'su -' (su mellomrom minus) først, før du tar 'yast2 sysconfig'.

Erfaren
Brukerens avatar
medlem i 198 måneder
 

Re: Språket til systemet

Innleggav singer » søn 28.10.2012 14:10

Dette fikk jeg når jeg limte inn eksempelet du ga meg 28-10 kl 10.40

linux-pp3x:/home/privat # cat /etc/sysconfig/language | grep RC_LANG
# Local users will get RC_LANG as their default language, i.e. the
RC_LANG="nb_NO.UTF-8"
linux-pp3x:/home/privat # # Local users will get RC_LANG as their default language, i.e. the
linux-pp3x:/home/privat # RC_LANG="nb_NO.UTF-8"



skal teste den du ref til i forrige innlegg:
Root behøver du bare være for å starte YaST modulen, og da tar du
'su -' (su mellomrom minus) først, før du tar 'yast2 sysconfig'.


Får opp config vindu med su mellomrom og passord når jeg limer inn:yast2 sysconfig
til venstre åpner jeg system men har ikke noen ting å velge (blankt) jeg får ikke opp alternativene som bilde ditt viser under system
Sist endret av singer den søn 28.10.2012 15:06, endret 1 gang

Brukerens avatar
medlem i 185 måneder
 

Re: Språket til systemet

Innleggav terjejh » søn 28.10.2012 15:00

singer skrev:linux-pp3x:/home/privat # cat /etc/sysconfig/language | grep RC_LANG
# Local users will get RC_LANG as their default language, i.e. the
RC_LANG="nb_NO.UTF-8"

Ut fra dette å bedømme skal du ha Norsk bokmål satt som språk.
Men jeg skjønner ikke hvorfor du fortsatt har root-prompten # foran kommandoen du kjører.
Når du åpner en Gnome-terminal første gang (før du tar su osv, skal du se bruker-prompten > ?
Post utskriften av denne kommandoen
Kode: Merk alt
id


Da kom det opp et vindu hvor det står
/etc/sysconfig Editor
til venstre står applicat desktop hardware network other, alt er ellers blankt

Det skal stå System nederst i venstre kollonne. Utvid trestrukturen nedover (pilspissene > eller pluss + tegnene), slik jeg viste på skjermbildet tidligere.

Erfaren
Brukerens avatar
medlem i 198 måneder
 

Re: Språket til systemet

Innleggav singer » søn 28.10.2012 15:15

privat@linux-pp3x:~> su
Passord:
linux-pp3x:/home/privat # id
uid=0(root) gid=0(root) groups=0(root)
linux-pp3x:/home/privat #

dette fikk jeg ved å lime inn id

jeg har nå fått til å følge bilde og oppskriften etter anvisning du ga meg
, men har fortsatt ikke norsk Gnome
Tidligere lastet jeg ned 360mb fra legg tilprogramer, men husker ikke hva som ble installert men hadde Norsk for en uke siden....
Installerte suse på nytt i dag men fortsatt ikke Norsk Gnome
Under yaST språk står det Norsk men under kolonne Norsk kan jeg huke av får tilpass tastauroppsett til Norsk
tilpass tidssone europa/norge men på disse 2 får jeg ikke huket av vet ikke om det har noen betydning.

Kan det ligge en fil i legg tilprogrammer som jeg mangler hmm

Brukerens avatar
medlem i 185 måneder
 

Re: Språket til systemet

Innleggav terjejh » søn 28.10.2012 19:10

singer skrev:privat@linux-pp3x:~> su
Passord:
linux-pp3x:/home/privat # id
uid=0(root) gid=0(root) groups=0(root)
linux-pp3x:/home/privat #

Jeg prøvde å få deg til å kjøre "id" kommandoen aller først (uten å kjøre su til root), for å få verifisert at du virkelig var innlogget som vanlig bruker. Det tror jeg nå at du er likevel.

Tidligere lastet jeg ned 360mb fra legg tilprogramer, men husker ikke hva som ble installert men hadde Norsk for en uke siden....
Kan det ligge en fil i legg tilprogrammer som jeg mangler hmm

Ja, ikke vet jeg. Noe har du åpenbart fått rotet til, ettersom dette skal fungere greitt uten vanskeligheter overhodet.

Du jo prøve følgende;
Åpne en Gnome-terminal, kjør "su -" og gi inn passord. Så kjører du følgende kommando for å prøve å installere alle tilgjengelige norske språkpakker. Systemet varsler og installerer ikke dem du har fra før, men du får antagelig flere enn du trenger (# tegnet er ikke en del av kommandoen, kun for å indikere rot-rettigheter):
Kode: Merk alt
# zypper in '*-nb'


Installerte suse på nytt i dag men fortsatt ikke Norsk Gnome
Under yaST språk står det Norsk men under kolonne Norsk kan jeg huke av får tilpass tastauroppsett til Norsk
tilpass tidssone europa/norge men på disse 2 får jeg ikke huket av vet ikke om det har noen betydning.

Språkoversettelser av skrivebordet og systemet har ikke noe med om tastatur-utlegget er Norsk eller ikke.

Følgende skjermbilder og valg under installasjonen sikrer strømlinjeformet installasjon og oppsett av Norsk språk allerede fra installasjonen av:

1. Boot skjermen, bruk funksjonstast F2 og velg Norsk installasjonsspråk
http://doc.opensuse.org/documentation/h ... l#id351601

2. Velkomstskjermen, verifiser at Norsk tastatur er valgt
http://doc.opensuse.org/documentation/h ... l#id439389

3. Klokke og Tidssone, verifiser at Europa og Norge/Oslo er valgt
http://doc.opensuse.org/documentation/h ... l#id439842

4. Installasjons setting skjermen, Lokal språklenke: velg/verifiser Norsk bokmål som primært språk, velg Engelsk som sekundært tilleggsspråk
http://doc.opensuse.org/documentation/h ... l#id308258

Som du allerede nevnt i ny post "Formattering", kan du under installasjonen velge å formattere eksisterende /home partisjon. Da får du rensket opp i eventuelle konfigurasjonsfeil i tidligere brukerfiler som henger igjen der. Men husk først: Ta backup/kopi av brukerdata som du skal beholde.

Erfaren
Brukerens avatar
medlem i 198 måneder
 

Re: Språket til systemet

Innleggav singer » søn 28.10.2012 19:22

Hei takk for svar fra deg!
Fåroppe følgende dvs hva kan jeg gjøre feil:-

privat@linux-mf9d:~> su
Passord:
linux-mf9d:/home/privat # zypper in '*-nb
>
Sist endret av singer den søn 28.10.2012 19:29, endret 1 gang

Brukerens avatar
medlem i 185 måneder
 

Re: Språket til systemet

Innleggav terjejh » søn 28.10.2012 19:26

Du har ikke fått med deg den siste appostrofen i: '*-nb'

Erfaren
Brukerens avatar
medlem i 198 måneder
 

Re: Språket til systemet

Innleggav singer » søn 28.10.2012 19:34

Melding ser sånn ut

linux-mf9d:/home/privat # zypper in '*-nb'
Kunne ikke montere cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_CDDVDW_TS-L633F_R8356GRB622029,/dev/sr0 på /var/adm/mount/AP_0xsLKtDY: Mounting media failed (mount: no medium found on /dev/sr0)

Sett inn mediet [] # 1 og tast 'y' for å fortsette eller 'n' for å avbryte handlingen. [ja/nei] (nei):

Fikk lastet pakker nå i orden takk:)
Da fikk begge rett det manglet noen pakker.. :-)

Hvor finner du komandoene som du gjorde nå?

Brukerens avatar
medlem i 185 måneder
 

Re: Språket til systemet

Innleggav terjejh » søn 28.10.2012 21:27

singer skrev:linux-mf9d:/home/privat # zypper in '*-nb'
Kunne ikke montere cd:///?devices=/dev/disk/by-id/ata-TSSTcorp_CDDVDW_TS-L633F_R8356GRB622029,/dev/sr0 på /var/adm/mount/AP_0xsLKtDY: Mounting media failed (mount: no medium found on /dev/sr0)

Sett inn mediet [] # 1 og tast 'y' for å fortsette eller 'n' for å avbryte handlingen. [ja/nei] (nei):

Fikk lastet pakker nå i orden takk:)

Som jeg skrev, # var ikke en del av kommandoen og skal derfor ikke kopieres.

Jeg bruker å deaktivere installasjonsmediet (cd/dvd) som pakkebrønn etter installasjonen. Dette sikrer at nyeste, oppdaterte pakker lastes ned fra online pakkebrønner, som legges inn under installasjonen.

Disabling kan også gjøres på to måter.
alt. 1) Med zypper kommandoer som root i terminal:
Liste alle pakkebrønner
Kode: Merk alt
zypper lr

Disable pakkebrønn nr 6 (forutsatt at cd;//... listes med nr 6 foran)
Kode: Merk alt
zypper mr -d 6

alt. 2) Med YaST2 gui som root i terminal
Kode: Merk alt
yast2 repositories &

Marker cd;//... pakkebrønnen, trykk Disable og OK

Nå kan det samtidig være på sin plass å kjøre en oppgradering av det installerte systemet ditt, i tilfelle det ikke er up-to-date:
Kode: Merk alt
zypper up


Da fikk begge rett det manglet noen pakker.. :-)

Det spørs, det kan også ha vært språkpakker som ikke trengtes som ble lagt til. Fikk du forresten Norsk etter ut og innlogging etterpå?

Hvor finner du komandoene som du gjorde nå?

Kunnskap erverves gjennom erfaring og ved å studere dokumentasjonen, jfr liste nedenfor. Navnemønstret måtte jeg selv prøve meg fram til.

Zypper kommandobasert pakkebehandler:
Zypper portal
http://en.opensuse.org/Portal:Zypper
Zyppper Usage
http://en.opensuse.org/SDB:Zypper_usage ... positories
Og online i terminalen
    man zypper
    zypper -h

    YaST gui kontrollsenter og verktøy:
    YaST portal og software management
    http://en.opensuse.org/Portal:YaST
    http://en.opensuse.org/Portal:YaST
    Og online i terminalen
      man yast2
      yast2 -l
      yast2 -h

    Erfaren
    Brukerens avatar
    medlem i 198 måneder
     

    Re: Språket til systemet

    Innleggav singer » søn 28.10.2012 22:14

    Fikk du forresten Norsk etter ut og innlogging etterpå?

    Nei måtte restarte maskin.Takk for linker!

    Nå kan det samtidig være på sin plass å kjøre en oppgradering av det installerte systemet ditt, i tilfelle det ikke er up-to-date:
    har kjørt update med programvare oppdatering ikonet under programmer.prøvde i terminal der fikk jeg beskjed: ingenting å gjøre.

    Brukerens avatar
    medlem i 185 måneder
     

    Forrige

    Returner til OpenSUSE



    Hvem er i Forumene

    Registrerte brukere: Google [Bot]