openSUSE 11.4 er ute

openSUSE 11.4 er ute

Innleggav Tertitten » tor 10.03.2011 16:28

Heisann, i "dag" slapp openSUSE utviklerne openSUSE 11.4 offisielt.
Jeg har selv brukt opensuse 11.4 en liten stund (siden RC2) og må si jeg er meget godt fornøyd, tror faktisk dette er en av de mest stabile utgivelsene jeg har testet på veeeeldig lenge. KDE 4.6 oppleves som rock solid og det samme gjør resten, det er en rekke nytt i 11.4 som du kan lese mer om her: http://news.opensuse.org/2011/03/10/opensuse-11-4/

For de som har lyst til å teste en distribusjon for første gang anbefaler jeg glatt denne, både gnome versjonen og kde versjonen oppleves som rock solid, og det er minimalt med problemer å takle i denne distribusjonen.

I motsetning til i 11.3 er nvidia driveren med allerede fra start i 11.4, så det er ingen behov for å vente denne gangen. .

Brukerens avatar
medlem i 155 måneder
 

Re: openSUSE 11.4 er ute

Innleggav olavpet » fre 11.03.2011 18:29

Jeg installerte 11.4 både på skrivebordsmaskin og nettbok i dag - og openSUSE med KDE er som ventet kjapt og stabilt.

Det eneste var at jeg mislyktes med å installere KDE-Live-CD-en på nettboka fra minnepinne. Installasjonen bare stoppet halvveis uten feilmeldinger.

Det kan hende det var noe galt med diskbildet, men jeg la inn NET-isoen på minnepinnen i stedet, og da gikk det greit.
medlem i 157 måneder
 

Re: openSUSE 11.4 er ute

Innleggav kupuna » lør 12.03.2011 19:00

I går oppgraderte jeg min stasjonære og min bærbare fra openSUSE 11.3 (med KDE 4.6.1) til 11.4 med "zypper up rpm" (en bug krever denne) og "zypper dup". Bortsett fra litt rydding i noen avhengigheter underveis, gikk oppgraderingene problemfritt på begge maskinene.

I forkant av oppgraderingen må adressene til pakkebrønnene korrigeres manuelt (Yast), stort sett fra "11.3" til "11.4". For noen repoer er det litt mer å gjøre. F.eks. har Packman nå 4 repoer. (Se openSUSE Forums.)

Min bærbare HP ProBook 6555b har Broadcom trådløs brikke. Den nyter nå godt av støtten i den nye kjernen, og driverne i Packman er ikke lenger nødvendige. ATI har foreløpig ikke klar en offisiell driver for Radeon-brikken, men den nye open source Radeonhd-driveren er betydelig forbedret, så behovet for proprietær driver er ikke så påtrengende som før.

Subpixel-støtte er nødvendig for å få et godt skriftbilde. freetype2-feature-subpixel-hinting fra http://download.opensuse.org/repositori ... SUSE_11.4/ ordner den jobben.
Sist endret av kupuna den lør 12.03.2011 22:57, endret 1 gang
medlem i 144 måneder
 

Re: openSUSE 11.4 er ute

Innleggav Tertitten » lør 12.03.2011 22:52

Man må altså ikke legge inn alle packman repoene, de er delt opp for å bli oversiktlige ettersom de vedlikeholder en hel del pakker, men det rekker med å legge til f.eks http://ftp.uni-erlangen.de/pub/mirrors/ ... SUSE_11.4/ ... ved å gjøre dette får man tilgang til alle pakkene i packman repoene, ønsker man oversikt kan man legge til hvilken som helst av:
Essentials
Extra
Games
Multimedia
Eller man kan legge til alle, eller altså "root repoet"

Angående Subpixel, freetype font osv, I følge utviklerne av opensuse skal man ikke behøve å installere noe som helst ekstra for å få subpixel hinting i 11.4, men jeg har også installert dette da jeg ikke helt stoler på at det ikke behøves. .

Brukerens avatar
medlem i 155 måneder
 

Re: openSUSE 11.4 er ute

Innleggav kupuna » lør 12.03.2011 22:58

@Tertitten
Du har selvfølgelig helt rett. :-)

...og etter at jeg på begge maskinene har avinstallert freetype-pakken og repoet som skal sørge for subpixel-rendering, så klarer jeg ikke å se noen forskjell. (ATI-brikke med 1366x768-skjerm og Nvidia-brikke med 1920x1200-skjerm.)
medlem i 144 måneder
 

Re: openSUSE 11.4 er ute

Innleggav unbob » søn 13.03.2011 13:18

Kanskje du ikke har slått det på. Delpunktsopptegning er ikke "slått på" i den offisielle libfreetype6 pakken.
Det er vanskelig (syns jeg ihvertfall) å se forskjell på om delpunktsopptegning er av eller på. Forskjell kommer også an på hvilken font en bruker, størrelse, osv. Viser ikke så godt som på skrivebordet men her er gif animasjoner fra YaST og en meny med og uten delpunktsopptegning:
Bilde Bilde

Om det er på, kan du sjekke med å ta skjermbilde av skriftinstallereren i systeminnstillinger og så zoome skjermbilde inn på eksempelteksten etterpå.
F.eks. Liberation Sans største demo V i 800%, med delpunktsopptegning og uten:
Bilde

Jeg installerer libfreetype6 fra grenen til Fisiu. Eneste forskjell på original og gren er
Kode: Merk alt
-%define enable_subpixel_rendering 0
+%define enable_subpixel_rendering 1

Installasjon kan gjøres på følgende vis:
Kode: Merk alt
zypper ar -f http://download.opensuse.org/repositories/home:/Fisiu:/lcd/openSUSE_11.4/home:Fisiu:lcd.repo
zypper mr -p 90 home_Fisiu_lcd
zypper in home_Fisiu_lcd:libfreetype6
Logg av og på.

Delpunktsopptegning må slås på i Systeminnstillinger -> Programutseende -> Skrifttype
Bilde

Brukerens avatar
medlem i 179 måneder
 

Re: openSUSE 11.4 er ute

Innleggav kupuna » tir 15.03.2011 10:10

Da er også ATI sin fglrx-driver på plass.
Jeg vet ikke om det er synsing, men jeg mener å ha erfart fra openSUSE 11.3 at fglrx-driveren drar mindre strøm fra batteriet enn hva open source radeon-driveren gjør. ATI Catalyst Control Center har en "PowerPlay"-innstilling. Noe tilsvarende finner jeg ikke for open source-driveren.
medlem i 144 måneder
 

Re: openSUSE 11.4 er ute

Innleggav Philip67 » tir 15.03.2011 19:55

Er det noen som har klart å oppdatere systeme?

Brukerens avatar
medlem i 151 måneder
 

Re: openSUSE 11.4 er ute

Innleggav Tertitten » tir 15.03.2011 21:25

Phillip; hva er det du spør om egentlig ?

Brukerens avatar
medlem i 155 måneder
 

Re: openSUSE 11.4 er ute

Innleggav Philip67 » ons 16.03.2011 14:42

Hver gang jeg installerer systemet, kliker jeg på online update i yast så laster jeg ned masse programer.Nå får jeg det ikke til.

Brukerens avatar
medlem i 151 måneder
 

Re: openSUSE 11.4 er ute

Innleggav Tertitten » ons 16.03.2011 15:31

Ta frem ett terminal vindu (Trykk f.eks ALT+F2 og skriv terminal om du ikke finner det i menyen)

skriv
Kode: Merk alt
su -
skriv inn ditt root passord (samme passord som brukerkonto om du ikke spesifiserte annet)

Skriv så
Kode: Merk alt
zypper ref
Enter, om ikke suse repos er satt opp vil zypper nå automatisk laste ned repo oppsett filene og sette opp repoer.

Skriv så:
Kode: Merk alt
zypper up
Enter, dette vil dra ned de nyeste oppdateringen tilgjengelige i default repos...

Brukerens avatar
medlem i 155 måneder
 

Re: openSUSE 11.4 er ute

Innleggav rbh » tor 26.05.2011 8:54

Har i dag 11.1 (Satt opp av "admin" på en vmware server) Har ikke grafisk grensesnitt, men har brukt YAST2 (tekst basert) til å sette opp LAMP. Fikk feil på automatisk oppdatering, Programvare (online-oppdatering).

Så til spørsmålet... Kan man oppgradere rett til 11.4
og hvordan går man frem når man ikke har grafisk versjon av YAST?
medlem i 152 måneder
 

Re: openSUSE 11.4 er ute

Innleggav terjejh » tor 26.05.2011 11:23

11.1 er gammel og ikke lenger offisielt støttet (EOS). Dette er nok også årsak til feilmeldingen du får ved forsøk på automatisk oppdatering.

openSUSE-fellesskapet har imidlertid igangsatt et prosjekt kalt "Evergreen", som er en langtidsstøtte (LTS) for openSUSE v. 11.1 og 11.2.
Dette har ikke jeg prøvd, men prosjektsiden viser hvordan oppdatering fra denne pakkebrønnen gjøres med kommandolinjeverktøyet 'zypper'
http://en.opensuse.org/openSUSE:Evergreen

Selv ville jeg ikke eksperimentert med en direkteoppgradering fra 11.1 til 11.4, i hvertfall ikke hvis dette er en server du er avhengig av. Du kan godt ende opp med et system som ikke fungerer etterpå. Skal du ha 11.4, er det tryggeste og reneste er ny installasjon fra CD/DVD.

Live-oppgraderinger med 'zypper dup' trinnvis fra 11.1 til 11.2 osv. kan kanskje fungere bedre. Dette dokumentet viser hvordan 11.1 kunne oppdateres til en pre-11.2. Men bytt ut 'factory' med 'distribution/11.2/' osv. i lenkene til pakkebrønnene, dvs.
http://download.opensuse.org/distribution/11.2/
http://lizards.opensuse.org/2009/10/01/ ... 1-to-11-2/

--------------------

Om man ikke har X gui installert på openSUSE serveren, kan man likevel kjøre YaST2 gui fra en nettverkstilknyttet arbeidsstasjon med X11. Det fine med YaST adminverktøyene er at det er rene X-applikasjoner, som kan displayes remote på en annen maskin (ssh med X-forwarding). Selv gjør jeg følgende fra en lokal terminal på min arbeidsstasjon:

Kode: Merk alt
ssh -X ip-til-server
su (på server)
yast2

Nå kommer YaST hovedmenyen opp, og man velger verktøy som normalt. Sitter man på lokalnettet er hastigheten god, sitter man remote over en typisk ADSL linje vil X gå tregere/tregt, men fungerer brukbart for "av og til" behov. (For permanent rask remote aksess med YaST gui, må man enten intallere WebYaST (ikke komplett) for 11.4 eller kjøre standard YaST eks. via NX, som igjen krever X og NX på serveren)

Erfaren
Brukerens avatar
medlem i 198 måneder
 

Re: openSUSE 11.4 er ute

Innleggav rbh » tor 26.05.2011 15:53

Live-oppgraderinger med 'zypper dup' trinnvis fra 11.1 til 11.2 osv. kan kanskje fungere bedre. Dette dokumentet viser hvordan 11.1 kunne oppdateres til en pre-11.2. Men bytt ut 'factory' med 'distribution/11.2/' osv. i lenkene til pakkebrnnene, dvs.
http://download.opensuse.org/distribution/11.2/
http://lizards.opensuse.org/2009/10/01/ ... 1-to-11-2/


Endret disse i url over
Kode: Merk alt
zypper ar -f http://download.opensuse.org/update/11.2/ "openSUSE 11.2 Updates"
zypper ar -f http://download.opensuse.org/distribution/11.2/repo/oss/ "openSUSE Factory Oss"
zypper ar -f http://download.opensuse.org/distribution/11.2/repo/non-oss/ "openSUSE Factory Non-Oss"
zypper ar -f http://download.opensuse.org/distribution/11.2/repo/debug/ "openSUSE Factory Debug"


fikk en feil med siste
Det oppstod en feil under initialisering av arkiv.
'openSUSE Factory Debug': [|] Ingen gyldige metadata
funnet p spesifisert(e) nettadresse(r)
Historie:
- [|] Repository type can't be determined.

Fjernet selvsagt den som feilet med
zypper rr http://download.opensuse.org/distributi ... epo/debug/ "openSUSE Factory Debug"

Fikk endelig startet vnc, etter ha endret brannmur innstillinger via yast. Startet YAST i vnc-veiwer, men lurer n p om jeg har rota ting til....


Ja jeg skjnner at navnet som kommer i parantes er bare ett navn... MEN det jeg hadde er/var en en linux enterprise server 11.2 for vmware
alle disse pakkene jeg la til var det rett type pakker for en enterprise server? (alst en maskin som skal st som en lamp server i vmware)??
medlem i 152 måneder
 

Re: openSUSE 11.4 er ute

Innleggav terjejh » tor 26.05.2011 22:15

Vops, nå ble jeg usikker på hva du egentlig har hatt installert, den frie openSUSE eller den kommersielle bedriftsversjonen SUSE Linux Enterprise Server (SLES)? Har du hatt det siste, har du antagelig fått mikset sammen pakker fra den siste oppdateringen.

I første epost sa du 11.1 på en vmserver, med spørsmål om mulighet for å oppgradere til 11.4. Ut fra dette antok jeg du hadde openSUSE 11.1. I siste epost sier du linux enterprise server 11.2 for vmware..

Den kommersielle versjonen SLES har hovedversjonsnr 11 pluss ev. servicepack nivå nr med LTS. Siste utgave er såvidt jeg vet ft. SLES 11 SP1. Sistnevnte har også kommersiell vedlikeholdssupport LTS på årsbasis.. Om du ikke fikk oppdatere sistnevnte, kan det skyldes at det inkluderte vedlikeholdet ved kjøpet er gått ut og at dere ev. ikke har abonnnert på videre betalt vedlikehold (?)

Slik kan du sjekke hvilken versjon du har installert:
Kode: Merk alt
cat /etc/SuSE-release
uname -a


Hekter her bare på noen relevante lenker for SLES 11 support

SUSE Linux Enterprise Server 11 SP1 for VMware
http://download.novell.com/Download?bui ... RHaoHcER0~
http://www.vmware.com/products/sles-for ... =firefox-a

Patches
http://support.novell.com/patches.html
Patch Finder
http://download.novell.com/patch/finder ... &keywords=

Erfaren
Brukerens avatar
medlem i 198 måneder
 

Neste

Returner til OpenSUSE



Hvem er i Forumene

Registrerte brukere: Google [Bot]