chrome for suse

chrome for suse

Innleggav Philip67 » ons 01.06.2011 14:04

Hei.
Jeg har installert google chrome fra denne siden.http://www.google.com/intl/en/landing/chrome/beta/
problemen er at ikonen finnes på applicatoins men når jeg klikker på den skjer det ingenting :-(
noen som vet hvordan jeg kan fikse den?
takk for hjelpen

Brukerens avatar
medlem i 149 måneder
 

Re: chrome for suse

Innleggav moma » ons 01.06.2011 14:27

hei,
Prøv å starte "google-chrome" fra kommandolinjen. Da vil du se evt. feilmeldinger.
$ google-chrome

Erfaren
Brukerens avatar
medlem i 214 måneder
 

Re: chrome for suse

Innleggav Philip67 » ons 01.06.2011 14:36

takk for svare
Feilmeldingen er den:

/bin/google-chrome: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory

Brukerens avatar
medlem i 149 måneder
 

Re: chrome for suse

Innleggav moma » ons 01.06.2011 15:15

Hei,
Du mangler "libpng12" pakken. Se denne feilmeldingen.
http://www.google.com/support/forum/p/C ... 8c50&hl=en
Håper du finner pakken i ditt system. Jeg antar du kjører openSUSE 11.4?

Erfaren
Brukerens avatar
medlem i 214 måneder
 

Re: chrome for suse

Innleggav hailstiffler » ons 01.06.2011 15:45

libpng12 finnes ja, bare å installere og problemet forsvinner :)
medlem i 136 måneder
 

Re: chrome for suse

Innleggav Philip67 » ons 01.06.2011 17:49

Yep.Det virker nå :-D :-D
Mange takk for hjelpen

Brukerens avatar
medlem i 149 måneder
 

Re: chrome for suse

Innleggav terjejh » ons 01.06.2011 22:02

Bare noen kommentarer og betraktninger:
Det har vært litt finurligheter mht. Chrome pakkens avhengigheter, som lsb og libpng, gjelder også for den stabile versjonen. Jeg installerte sistnevnte på Tumbleweed med pakkebehandleren zypper, som automatisk la til følgende avhengigheter:
Kode: Merk alt
# zypper in google-chrome-stable_current_x86_64.rpm
........
Resolving package dependencies...

The following NEW packages are going to be installed:
  glibc-i18ndata google-chrome-stable kdelibs3-default-style lsb m4 patch qt3

The following recommended package was automatically selected:
  kdelibs3-default-style

7 new packages to install.

Pakkebrønnen legges automatisk til, slik at framtidige oppdateringer av chrome vil bli tilgjengelig:
Kode: Merk alt
~> zypper lr -u | grep chrome
 6 | google-chrome                          | google-chrome                          | Ja       | Ja       | http://dl.google.com/linux/chrome/rpm/stable/x86_64

Også her måtte libpng etterinstalleres, en avhengighet som heller ikke framkommer i rpm pakken:
Kode: Merk alt
~> rpm -q --requires google-chrome-stable-11.0.696.71-86024.x86_64
rpmlib(VersionedDependencies) <= 3.0.3-1
lsb >= 3.2
libasound.so.2()(64bit) 
libcairo.so.2()(64bit) 
libcurl.so.4()(64bit) 
libgconf-2.so.4()(64bit) 
libnss3.so(NSS_3.12.3)(64bit) 
libpangocairo-1.0.so.0()(64bit) 
libsqlite3.so.0()(64bit) 
libbz2.so.1()(64bit) 
libXss.so.1()(64bit) 
libjpeg.so.62()(64bit) 
wget 
xdg-utils 
zlib 
/bin/sh 
/bin/sh 
/bin/sh 
/bin/sh 
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
rpmlib(PayloadIsBzip2) <= 3.0.5-1


Jeg la så til den uoffisielle Contrib pakkebrønnen med YaST pakkebehandleren, og installerte Chromium via samme. Sjekket også her rpm avhengighetene, og fikk en noe lengre liste, som omfattet også libpng:
Kode: Merk alt
terje@linux-jx9q:~> rpm -q --requires chromium-13.0.782.0-2.1.x86_64
rpmlib(VersionedDependencies) <= 3.0.3-1
alsa 
xdg-utils 
libv8-3 = 3.4.0.1
rpmlib(PartialHardlinkSets) <= 4.0.4-1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1
/bin/sh 
ld-linux-x86-64.so.2()(64bit) 
ld-linux-x86-64.so.2(GLIBC_2.3)(64bit) 
libX11.so.6()(64bit) 
libXext.so.6()(64bit) 
libXrender.so.1()(64bit) 
libXss.so.1()(64bit) 
libasound.so.2()(64bit) 
libasound.so.2(ALSA_0.9)(64bit) 
libasound.so.2(ALSA_0.9.0rc4)(64bit) 
libbz2.so.1()(64bit) 
libc.so.6()(64bit) 
libc.so.6(GLIBC_2.11)(64bit) 
libc.so.6(GLIBC_2.2.5)(64bit) 
libc.so.6(GLIBC_2.3)(64bit) 
libc.so.6(GLIBC_2.3.4)(64bit) 
libc.so.6(GLIBC_2.4)(64bit) 
libc.so.6(GLIBC_2.7)(64bit) 
libc.so.6(GLIBC_2.8)(64bit) 
libcairo.so.2()(64bit) 
libcups.so.2()(64bit) 
libdbus-1.so.3()(64bit) 
libdbus-glib-1.so.2()(64bit) 
libdl.so.2()(64bit) 
libdl.so.2(GLIBC_2.2.5)(64bit) 
libevent-1.4.so.2()(64bit) 
libexpat.so.1()(64bit) 
libfontconfig.so.1()(64bit) 
libfreetype.so.6()(64bit) 
libgcc_s.so.1()(64bit) 
libgcc_s.so.1(GCC_3.0)(64bit) 
libgcc_s.so.1(GCC_4.0.0)(64bit) 
libgconf-2.so.4()(64bit) 
libgcrypt.so.11()(64bit) 
libgcrypt.so.11(GCRYPT_1.2)(64bit) 
libgdk-x11-2.0.so.0()(64bit) 
libgdk_pixbuf-2.0.so.0()(64bit) 
libglib-2.0.so.0()(64bit) 
libgobject-2.0.so.0()(64bit) 
libgthread-2.0.so.0()(64bit) 
libgtk-x11-2.0.so.0()(64bit) 
libjpeg.so.62()(64bit) 
libm.so.6()(64bit) 
libm.so.6(GLIBC_2.2.5)(64bit) 
libnspr4.so()(64bit) 
libnss3.so()(64bit) 
libnss3.so(NSS_3.10)(64bit) 
libnss3.so(NSS_3.11)(64bit) 
libnss3.so(NSS_3.11.1)(64bit) 
libnss3.so(NSS_3.11.2)(64bit) 
libnss3.so(NSS_3.12)(64bit) 
libnss3.so(NSS_3.12.3)(64bit) 
libnss3.so(NSS_3.2)(64bit) 
libnss3.so(NSS_3.3)(64bit) 
libnss3.so(NSS_3.4)(64bit) 
libnss3.so(NSS_3.5)(64bit) 
libnss3.so(NSS_3.6)(64bit) 
libnss3.so(NSS_3.7)(64bit) 
libnss3.so(NSS_3.8)(64bit) 
libnss3.so(NSS_3.9)(64bit) 
libnss3.so(NSS_3.9.2)(64bit) 
libnss3.so(NSS_3.9.3)(64bit) 
libnssutil3.so()(64bit) 
libnssutil3.so(NSSUTIL_3.12)(64bit) 
libpango-1.0.so.0()(64bit) 
libpangocairo-1.0.so.0()(64bit) 
libplc4.so()(64bit) 
libpng14.so.14()(64bit) 
libpng14.so.14(PNG14_0)(64bit) 
libpthread.so.0()(64bit) 
libpthread.so.0(GLIBC_2.2.5)(64bit) 
libpthread.so.0(GLIBC_2.3.2)(64bit) 
libresolv.so.2()(64bit) 
libresolv.so.2(GLIBC_2.2.5)(64bit) 
librt.so.1()(64bit) 
librt.so.1(GLIBC_2.2.5)(64bit) 
libsmime3.so()(64bit) 
libsmime3.so(NSS_3.2)(64bit) 
libspeex.so.1()(64bit) 
libstdc++.so.6()(64bit) 
libstdc++.so.6(CXXABI_1.3)(64bit) 
libstdc++.so.6(CXXABI_1.3.1)(64bit) 
libstdc++.so.6(GLIBCXX_3.4)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.11)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.14)(64bit) 
libstdc++.so.6(GLIBCXX_3.4.9)(64bit) 
libvpx.so.0()(64bit) 
libxml2.so.2()(64bit) 
libxslt.so.1()(64bit) 
libxslt.so.1(LIBXML2_1.0.11)(64bit) 
libxslt.so.1(LIBXML2_1.0.22)(64bit) 
libxslt.so.1(LIBXML2_1.0.24)(64bit) 
libxslt.so.1(LIBXML2_1.1.9)(64bit) 
libz.so.1()(64bit) 
libz.so.1(ZLIB_1.2.0)(64bit) 
rpmlib(PayloadIsLzma) <= 4.4.6-1

Erfaren
Brukerens avatar
medlem i 196 måneder
 


Returner til OpenSUSE



Hvem er i Forumene

Registrerte brukere: Google [Bot]