Maskinen får ikke koblet til WLAN

Forumet hvor ingen spørsmål er dumme, eller hvis du har et Linux- og BSD-relatert spørsmål som ikke passer i kategoriene nedenfor.

Maskinen får ikke koblet til WLAN

Innleggav Jarlexx » lør 19.01.2013 14:55

Jeg er ganske nybegynner med Linux, så har ikke så veldig mye greie på dette. Men jeg har holdt på en god stund med dette problemet, og uansett hva jeg prøver, fikser det ikke problemet.

Problemet er at maskinen min ikke klarer å opprette en forbindelse med nettverket. WiFi og alt fungerer fordi den finner nettverket mitt, jeg kobler til, taster inn WEP-nøkkel og den prøver å koble til. Den holder på lenge, og mange ganger, men det eneste som kommer opp er "Connection Failed - Activation of network connection failed" etterfulgt av "Wireless network Disconnected - You are now offline".

Det som er merkelig er at den fungerer innimellom! Det fungerte fint under installasjonen av OS'et, og har fungert problemfritt noen få tilfeldige ganger. Men for det meste kommer disse meldingene opp.

Jeg har prøvd både Ubuntu 12.10 og er nå på Linux Mint 14 "Nadia" - Cinnamon.
Maskinen er en Point of View Mobii Notebook (http://www.pointofview-online.com/showroom.php?shop_mode=product_detail&product_id=80)
Nettverkskortet er et Realtek r8169.

Jeg vet at jeg bør vise fram info gjennom noen koder i Terminal, men er litt usikker på hva dere trenger :) Håper noen kan hjelpe!

Brukerens avatar
medlem i 136 måneder
 

Re: Maskinen får ikke koblet til WLAN

Innleggav petrus764 » søn 20.01.2013 13:25

Først av alt, er det noen spesiell grunn til at du bruker WEP?

WEP er den dårligste formen for kryptering man får, funker det om du bytter til WPA/WPA2?

Brukerens avatar
medlem i 186 måneder
 

Re: Maskinen får ikke koblet til WLAN

Innleggav Jarlexx » søn 20.01.2013 17:02

Beklager, var en skrivefeil der.. Er WPA jeg bruker :)

Har hentet info fra lspci og lsmod hvis det hjelper:

lspci:

Kode: Merk alt
00:00.0 Host bridge: NVIDIA Corporation MCP79 Host Bridge (rev b1)
00:00.1 RAM memory: NVIDIA Corporation MCP79 Memory Controller (rev b1)
00:03.0 ISA bridge: NVIDIA Corporation MCP79 LPC Bridge (rev b3)
00:03.1 RAM memory: NVIDIA Corporation MCP79 Memory Controller (rev b1)
00:03.2 SMBus: NVIDIA Corporation MCP79 SMBus (rev b1)
00:03.3 RAM memory: NVIDIA Corporation MCP79 Memory Controller (rev b1)
00:03.5 Co-processor: NVIDIA Corporation MCP79 Co-processor (rev b1)
00:04.0 USB controller: NVIDIA Corporation MCP79 OHCI USB 1.1 Controller (rev b1)
00:04.1 USB controller: NVIDIA Corporation MCP79 EHCI USB 2.0 Controller (rev b1)
00:06.0 USB controller: NVIDIA Corporation MCP79 OHCI USB 1.1 Controller (rev b1)
00:06.1 USB controller: NVIDIA Corporation MCP79 EHCI USB 2.0 Controller (rev b1)
00:08.0 Audio device: NVIDIA Corporation MCP79 High Definition Audio (rev b1)
00:09.0 PCI bridge: NVIDIA Corporation MCP79 PCI Bridge (rev b1)
00:0b.0 IDE interface: NVIDIA Corporation MCP79 SATA Controller (rev b1)
00:0c.0 PCI bridge: NVIDIA Corporation MCP79 PCI Express Bridge (rev b1)
00:10.0 PCI bridge: NVIDIA Corporation MCP79 PCI Express Bridge (rev b1)
00:15.0 PCI bridge: NVIDIA Corporation MCP79 PCI Express Bridge (rev b1)
00:16.0 PCI bridge: NVIDIA Corporation MCP79 PCI Express Bridge (rev b1)
00:17.0 PCI bridge: NVIDIA Corporation MCP79 PCI Express Bridge (rev b1)
00:18.0 PCI bridge: NVIDIA Corporation MCP79 PCI Express Bridge (rev b1)
03:00.0 VGA compatible controller: NVIDIA Corporation ION LE VGA (rev b1)
04:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 02)


lsmod:

Kode: Merk alt
Module                  Size  Used by
nls_iso8859_1          12617  1
uas                    17556  0
usb_storage            39350  1
snd_hda_codec_hdmi     31423  1
snd_hda_codec_realtek    63356  1
joydev                 17161  0
snd_hda_intel          32515  3
snd_hda_codec         111547  3 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel
snd_hwdep              13272  1 snd_hda_codec
snd_pcm                80163  3 snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
arc4                   12473  2
snd_seq_midi           13132  0
snd_rawmidi            25382  1 snd_seq_midi
rt73usb                26662  0
coretemp               13168  0
crc_itu_t              12627  1 rt73usb
microcode              18209  0
rt2x00usb              19941  1 rt73usb
rt2x00lib              48562  2 rt73usb,rt2x00usb
nouveau               823577  3
snd_seq_midi_event     14475  1 snd_seq_midi
mac80211              461161  2 rt2x00usb,rt2x00lib
snd_seq                51255  2 snd_seq_midi,snd_seq_midi_event
ttm                    75534  1 nouveau
drm_kms_helper         45271  1 nouveau
snd_timer              24411  2 snd_pcm,snd_seq
snd_seq_device         14137  3 snd_seq_midi,snd_rawmidi,snd_seq
drm                   230463  5 nouveau,ttm,drm_kms_helper
cfg80211              175375  2 rt2x00lib,mac80211
uvcvideo               71277  0
videobuf2_core         32070  1 uvcvideo
i2c_algo_bit           13197  1 nouveau
mxm_wmi                12859  1 nouveau
psmouse                84843  0
videodev               95841  2 uvcvideo,videobuf2_core
videobuf2_vmalloc      12756  1 uvcvideo
videobuf2_memops       13184  1 videobuf2_vmalloc
snd                    61991  16 snd_hda_codec_hdmi,snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_pcm,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
serio_raw              13031  0
shpchp                 32189  0
soundcore              14599  1 snd
snd_page_alloc         14036  2 snd_hda_intel,snd_pcm
i2c_nforce2            12869  0
parport_pc             31968  0
rfcomm                 37276  0
bnep                   17707  2
ppdev                  12817  0
bluetooth             183228  10 rfcomm,bnep
wmi                    18590  2 nouveau,mxm_wmi
video                  18847  1 nouveau
mac_hid                13037  0
lp                     13299  0
parport                40753  3 parport_pc,ppdev,lp


Brukerens avatar
medlem i 136 måneder
 

Re: Maskinen får ikke koblet til WLAN

Innleggav oyoy » søn 20.01.2013 18:04

Er ikke det kortet et (kablet) Ethernet-kort?
Ser ut som du har lastet noen drivere for USB nettverk også. Hva sier `lsusb`?

Brukerens avatar
medlem i 207 måneder
 

Re: Maskinen får ikke koblet til WLAN

Innleggav pider » søn 20.01.2013 19:18

Først:
Du bør ha kablet tilkobling til du har kjørt oppdatering, og aktivert eventuelt ekstra drivere. :-)

Har du skjekket at routeren din sender på "802.11b/g". Det hender at ruteren bare sender på /n. 8-)

Har installert driver? :-!

se her: http://en.opensuse.org/SDB:Realtek_8169_driver_problem

og her: https://build.opensuse.org/package/show ... vers%3Anic

Brukerens avatar
medlem i 233 måneder
 

Re: Maskinen får ikke koblet til WLAN

Innleggav mryia » man 21.01.2013 21:27

Realtek r8169 ser ut til å være kort med kabel, ikke wifi. Det høres jo ut som du har drivere siden du får søkt opp nettverket.
Får du opp trådløskortet om du skriver "ifconfig"? I så fall, prøv:

sudo nano /etc/network/interfaces
Legg til følgende tekst: (Det kan være at trådløskortet hos deg heter noe annet, f.eks eth1)

auto wlan0
iface wlan0 inet dhcp
wireless-power off

Trykk ctrl+x for å avslutte, velg y for å lagre.

Restart maskinen.

Brukerens avatar
medlem i 186 måneder
 

Re: Maskinen får ikke koblet til WLAN

Innleggav Jarlexx » ons 23.01.2013 2:59

oyoy skrev:Er ikke det kortet et (kablet) Ethernet-kort?
Ser ut som du har lastet noen drivere for USB nettverk også. Hva sier `lsusb`?


Kortet har ethernet også hvis det er det du mener. Det skal ikke ha noe med USB å gjøre. Fikk dette under "lsusb":

Kode: Merk alt
Bus 001 Device 002: ID 08dd:0120 Billionton Systems, Inc.
Bus 002 Device 002: ID 0ac8:3450 Z-Star Microelectronics Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub


pider skrev:Først:
Du bør ha kablet tilkobling til du har kjørt oppdatering, og aktivert eventuelt ekstra drivere. :-)

Har du skjekket at routeren din sender på "802.11b/g". Det hender at ruteren bare sender på /n. 8-)

Har installert driver? :-!

se her: http://en.opensuse.org/SDB:Realtek_8169_driver_problem

og her: https://build.opensuse.org/package/show ... vers%3Anic


Ja, routeren min skal ikke ha noe problem med det. Som sagt så har det fungert tidligere uten noen problemer, men for det meste vil det ikke fungere i det hele tatt.. Driverne ser ut til å fungere fint.

mryia skrev:Realtek r8169 ser ut til å være kort med kabel, ikke wifi. Det høres jo ut som du har drivere siden du får søkt opp nettverket.
Får du opp trådløskortet om du skriver "ifconfig"? I så fall, prøv:

sudo nano /etc/network/interfaces
Legg til følgende tekst: (Det kan være at trådløskortet hos deg heter noe annet, f.eks eth1)

auto wlan0
iface wlan0 inet dhcp
wireless-power off

Trykk ctrl+x for å avslutte, velg y for å lagre.

Restart maskinen.


Det er isåfall WiFi innebygget i maskinen, så kan vel hende jeg oppga feil ved r8169.. Under "ifconfig" fikk jeg opp:

Kode: Merk alt
eth0      Link encap:Ethernet  HWaddr 00:e0:4c:00:7d:29 
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)



Jeg fant nettopp ut at maskinen rett og slett ikke klarer å "Obtain IP adress". Så problemet ligger nok i det. Men jeg aner ikke hvordan jeg eventuelt kan løse det. Kan hende jeg må oppdatere firmwaren til nettverkskortet, men jeg vet ikke hvordan jeg gjør det.. :/

Brukerens avatar
medlem i 136 måneder
 


Returner til Hjelp! / Hvilken distribusjon? / Usortert



Hvem er i Forumene

Registrerte brukere: Google [Bot]